Sites have been blocked

Incident Report for AudienceView Campus

Resolved

The site is now restored and services are fully functional

Thanks for your patience while we quickly resolved this
Posted Feb 28, 2025 - 13:20 EST

Investigating

We are currently aware Sites are receiving a blocked error on Access

We are looking into this and will update you as soon as we know more
Posted Feb 28, 2025 - 13:00 EST
This incident affected: Ticketing Site.