Campus Printing
Incident Report for AudienceView Campus
Resolved
This incident has been resolved.
Posted Apr 19, 2022 - 22:37 EDT
Update
We are continuing to investigate this issue.
Posted Apr 19, 2022 - 21:57 EDT
Investigating
We are currently investigating an issue affecting Campus Printing.
Posted Apr 19, 2022 - 18:52 EDT
This incident affected: Printing.