Report Issue

Incident Report for AudienceView Campus

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 08:52 EST

Investigating

We are currently experiencing issues with reports loading on the Campus platform.

🔍 Current Status: Our teams are actively working to restore full functionality as soon as possible.

📢 Next Update: We will provide further updates as soon as more information becomes available.

We appreciate your patience and understanding.
Posted Nov 19, 2025 - 15:44 EST
This incident affected: Reporting.