Outbound Emails
Incident Report for AudienceView Campus
Resolved
This incident has been resolved and email service is now restored.
Posted Aug 11, 2021 - 19:04 EDT
Investigating
You may currently be experiencing issues with sending emails from your Campus site.
Posted Aug 11, 2021 - 16:18 EDT
This incident affected: Email/SMS Notification.